Аппаратное ускорение видео

Ответить

Автор темы
sergreyz
Сообщения: 18
Зарегистрирован: 16 фев 2017, 16:06

Аппаратное ускорение видео

#1

Сообщение sergreyz » 04 фев 2018, 01:34

Система версии 16.04.3.
Использую неттоп на процессоре Celeron N3000, он без активного охлаждения и сильно греется под нагрузкой
Аппаратное ускорение видео работает странно. Воспроизведение в браузере есть по 80-100% процессора.
Но ладно бразуер, если открывать тот же ютуб через VLC, то 720p ест по 30%, а 1080p - вплоть до 80% от процессора.
Решил установить windows для сравнения, и что интересно. В media player classic при выборе ускорения видео через quicksync повторяется та же ситуация - видео жрёт процессор, как и в lubuntu! А при выборе ускорения dxva - чудеса, 5%...
Я подозреваю, что надо попробовать попереключать и в lubuntu
Как узнать, какой вид ускорения используется в lubuntu, и переключить на другой? Я пробовал все настройки из меню VLC, но не помогло.

P.S. Винду не предлагать, 2 Гб ОЗУ - не увеличить.

Аватара пользователя

jazzbiker
Сообщения: 62
Зарегистрирован: 08 сен 2014, 16:02

Аппаратное ускорение видео

#2

Сообщение jazzbiker » 04 фев 2018, 04:47

Драйвера mesa-va-drivers установлены?


Автор темы
sergreyz
Сообщения: 18
Зарегистрирован: 16 фев 2017, 16:06

Аппаратное ускорение видео

#3

Сообщение sergreyz » 06 фев 2018, 21:35

jazzbiker писал(а):
04 фев 2018, 04:47
Драйвера mesa-va-drivers установлены?
До того не были. Сейчас попробовал - эффекта нет: Gnome с vaapi не показывает вообще, VLC с vaapi - показывает, но нагрузка та же.

Аватара пользователя

jazzbiker
Сообщения: 62
Зарегистрирован: 08 сен 2014, 16:02

Аппаратное ускорение видео

#4

Сообщение jazzbiker » 07 фев 2018, 20:20

Путаница имеет место быть. Gnome-mplayer действительно предлагает опцию vaapi для видеовыхода. Но он же является фронтом для mplayer. Смотрим варианты вывода видео в mplayer:
mplayer -vo help
и не видим там vaapi. То есть Gnome-mplayer не проверяет наличие драйверов а предлагает всевозможное варианты параметров, которые он передаст собственно mplayer'у, а там как карта ляжет.
Вот, например, Debian метапакет vdpau-driver-all устанавливает mesa-vdpau-drivers и libvdpau-va-gl1. В Ubuntu такого метапакета нет, надо эти два пакета поставить отдельно. Ещё есть пакет vdpau-va-driver, надо пробовать.
У меня AMD встроенная графика, так что я поставил mesa-vdpau-drivers и всё пошло-поехало. Но ленивые интела не хотят понимать vdpau, они хотят только своё va-api, вот и приходится добрым людям чесать репу в недоумении.

Аватара пользователя

jazzbiker
Сообщения: 62
Зарегистрирован: 08 сен 2014, 16:02

Аппаратное ускорение видео

#5

Сообщение jazzbiker » 08 фев 2018, 01:52

Кстати о vlc. Он у меня нормально заработал (то есть всю распаковку видео переложил на видеокарту) когда я задал ему устройство вывода видео vdpau, при этом в настройках самого vlc птицу "аппаратное ускорение видео" сбросил. Во как!

Ответить