Системные требования?


abml
Сообщения: 80
Зарегистрирован: 03 фев 2015, 15:29
Откуда: Москва

Re: Системные требования?

#21

Сообщение abml » 20 сен 2015, 13:01

Denkin, у меня 12.04. А насколько опасно в версии 12.04 (1) установить более "продвинутое" ядро; И ТАКЖЕ --- (2) установить более новый офис?
К п.1: у меня лежит WiFi адаптер, который, как я прочел на каком-то забугорном форуме, поддерживают ядра, ТОЛЬКО начиная с 3.14 (если я не путаю). А в 12.04 более старая цепочка ядер и никак не работает. В то же время 12.04 у меня работает суперстабильно на довольно старом железе и менять не вижу смысла (скорее всего будут проблемы).
И еще к п.1: Вы когда-то писали, как устанавливать ядра. Там была некая длинная строчка, которую можно написать только будучи очень трезвым. А покороче никак (где-то галочки поставить)? Thank you in advance.


Автор темы
bender670
Сообщения: 27
Зарегистрирован: 13 сен 2015, 09:24
Откуда: Иркутская область
Контактная информация:

Re: Системные требования?

#22

Сообщение bender670 » 20 сен 2015, 13:56

denkin, я имел ввиду годы 2010 и 2011 (хотел именно старую поставить, чтобы глянуть, будет мое древнее железо на ней работать). Завтра на работе попробую и позже отпишусь.

Аватара пользователя

denkin
Сообщения: 1884
Зарегистрирован: 07 сен 2011, 17:21
Контактная информация:

Re: Системные требования?

#23

Сообщение denkin » 20 сен 2015, 15:41

abml писал(а):Denkin, у меня 12.04. А насколько опасно в версии 12.04 (1) установить более "продвинутое" ядро; И ТАКЖЕ --- (2) установить более новый офис?...
неопасно, если не будет проблем с поддержкой железа.
на своей 14.04 использую ядро от 15.04 из основного репозитория
на 12.04 у супруги ядро от 14.04 из основного репозитория
на обоих системах новейший Либреофис 5.0.1 из дополнительного репозитория
abml писал(а):...И еще к п.1: Вы когда-то писали, как устанавливать ядра. Там была некая длинная строчка, которую можно написать только будучи очень трезвым. А покороче никак (где-то галочки поставить)? Thank you in advance.
какое ядро и в какую систему необходимо установить? Покороче и с галочками - в synaptic
(я, если честно совершенно не помню когда и где писал, дал решение, проверенное - а я всегда даю проверенные на себе решения, забыл :) )

Аватара пользователя

delvin-fil
Сообщения: 341
Зарегистрирован: 09 фев 2014, 12:05

Re: Системные требования?

#24

Сообщение delvin-fil » 21 сен 2015, 09:06

denkin писал(а):Более беспомощную ось, чем голая винда сразу после установки, вообще трудно себе представить.
Плюсую :beer:
adventurer писал(а):Чтобы какое-то устройство работало с ОС нужна программа взаимодействия, которая называется драйвер. С ОС могут поставляться универсальные драйверы.
Для *NIX систем не так. Драйверы включены в ядро. Процесс init через демон devfsd генерирует ФАЙЛЫ УСТРОЙСТВ(в них можно писать и из них можно читать - cat /dev/input/mouse0) на стадии загрузки. Затем подключаются ядерные модули(как правило тоже драйверы) не скомпилированные вместе с ядром(просмотр командой lsmod).
adventurer писал(а):Вот гентушники утверждают, что могут запустить любое оборудование
Вот NetBSD и QNX(проприетарная + realtime = НЕ ДЛЯ ДОМА) жрут реально ЛЮБОЕ железо!!! Впрочем и OpenBSD и MINIX тоже ;)
RE: я бывший Gentoo'шник 8)

Мое мнение: Если не получается найти ответы в инете, нет рядом гуру и не получается "методом тыка", но ОЧЕНЬ ХОЧЕТСЯ - абгрейдь машину. Поверь, осваивал установку генту по английскому handbook - работала как танк на Р-ММХ, 378Мб, 16Мб видео, 32Гб SCSI.


abml
Сообщения: 80
Зарегистрирован: 03 фев 2015, 15:29
Откуда: Москва

Re: Системные требования?

#25

Сообщение abml » 21 сен 2015, 12:38

denkin, уточните пож-та (см. выше): после установки, скажем, вместо (или плюс) ядра 3.2 ядра 3.5, какая ветка будет автоматом обновляться (1-я или 2-я)?

Аватара пользователя

delvin-fil
Сообщения: 341
Зарегистрирован: 09 фев 2014, 12:05

Re: Системные требования?

#26

Сообщение delvin-fil » 21 сен 2015, 12:59

abml писал(а):denkin, уточните пож-та (см. выше): после установки, скажем, вместо (или плюс) ядра 3.2 ядра 3.5, какая ветка будет автоматом обновляться (1-я или 2-я)?
Потянутся автоматом библиотеки gcc, binutils, kernel-headers и создадутся линки на более актуальные библиотеки.
У ядер вертикальная совместимость в пределах релиза, то есть эти либы и заголовки(libs & headers) не пойдут к ядрам ниже 3.0.
P.S:Раньше стабильность/нестабильность ядра отмечалась в номере версии. Например: 2.4 и 2.6 - стабильные, 2.5 и 2.7 - нестабильные.
P.P.S: Чуть не забыл, modules и headers ядер лежат в своих каталогах по номеру версии ядра, так что ничего страшного(кроме уменьшения свободного места на винте) не произойдет. У меня три ядра на выбор.

Аватара пользователя

denkin
Сообщения: 1884
Зарегистрирован: 07 сен 2011, 17:21
Контактная информация:

Re: Системные требования?

#27

Сообщение denkin » 21 сен 2015, 13:05

abml писал(а):denkin, уточните пож-та (см. выше): после установки, скажем, вместо (или плюс) ядра 3.2 ядра 3.5, какая ветка будет автоматом обновляться (1-я или 2-я)?
что значит "вместо"?

- если просто доустановить ядро Quantal в 12.04, например так, то будут обновляться обе ветки ядра и 3.2 и 3.5
- если установить ядро 3.5 и удалить ядро 3.2 полностью (с заголовками), то естественно 3.2 обновляться не будет

Удобнее всего удалять ядра с заголовками в синаптике, по тегам поиска типа kernel generic

Ответить