Установщик? ТРЕБУЕТ? РАЕ???

Здесь можно задавать любые вопросы по установке и настройке Lubuntu Linux

Модератор: Vadim

Аватара пользователя

Vadim
Модератор
Сообщения: 1420
Зарегистрирован: 14 дек 2012, 13:59
Откуда: Україна, місто Донецьк

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение Vadim » 20 янв 2014, 16:56

denkin,вот тут в ubuntu wiki https://help.ubuntu.com/community/PAE
написано что последний вариант ядра non-PAE - в xubuntu 12.04,и хоть с mini iso устанавливай,хоть с alternate ядро будет pae,другого ядра вообще в репозитории нет,не знаю зачем убрали(в дистрибутивах на репозиториях Debian-есть)
Единственный вариант - fake-pae
Моя країна - Україна!
Єдина країна. Единая страна.

Аватара пользователя

denkin
Сообщения: 1833
Зарегистрирован: 07 сен 2011, 17:21
Контактная информация:

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение denkin » 21 янв 2014, 00:30

очень жаль, что так, - о чем разрабы лубунту думают?

этак еще поддержку х32 уберут.


Автор темы
Вредятел
Сообщения: 94
Зарегистрирован: 23 янв 2012, 13:30

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение Вредятел » 21 янв 2014, 16:21

Да, что-то овиндели вконец :( Ладно, попробуем с этого боку.
Вводная: отсутствует не только флаг, но и сам РАЕ (это к вопросу об использовании фейка). Даже если это не так, будем решать общий случай.

Попытка номер раз: берём мощный десктоп, вкатываем туда 13.10, на данный момент последнюю. Далее сюда http://pingvinus.ru/note/linux-kernel-compile и пытаемся собрать ядро без РАЕ и стартовать с ним, чтобы проверить саму возможность дальше мирно жить. Я потёр изложения своих половых трудностей, мало кому интересные и только с толку сбивающие.

Итак, после соблюдения инструкции успешно сижу под пересобранным ядром с хаймемори = 4гб (а не 64) и, соответственно, вырубленной РАЕ (как проверить, кстати?). Всего один пунктик в списке перевыбрал и пересобрал, такие дела.

Теперь, естественно, вопрос: как мне это ядро вкорячить в дистрибутив, чтобы установщик стартовал с ним, а не с дефолтным? Главное -- прорваться, а там я всегда могу при обновлении каждый раз пересобирать ядро, а грузиться для этого на предыдущем. Ну не каждый же день эти ёдра новые выходят, чесслово. Всё равно я стараюсь пересобирать под себя ^_^ только лень обычно.
sudo leafpad /etc/default/keyboard... Боже, дай мне сил :(


Автор темы
Вредятел
Сообщения: 94
Зарегистрирован: 23 янв 2012, 13:30

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение Вредятел » 28 янв 2014, 15:55

Мдас. Помощи от вас...
Короче, меня тут один товарищ слегка проинструктировал, но всё равно имеем тупик.
1) Я взял каноничное содержимое (http://gnu.su/plugins/forum/forum_viewt ... p?331.post): конфиг, инитрд, вмлинуз и системмап из своего /boot. Вопреки названию, инитрд сжатый. Они у меня были готовые, потому что ядро без PAE, как вы помните, я потестировал и, следовательно, устанавливал на обычную машину. Они годятся или надо с какими-то особыми опциями собирать?
2) На alternate (менять -- так уж наименее требовательный к памяти, ессно) CD 13.10 я нашёл в /install виновника: ядро, вызывающее падение по PAE. Оно состоит только из вмлинуз и сжатого инитрд. Содержимое, характерное для конфига и системмапа, не обнаруживается на сидюке вообще. Где оно и как его заменять на соответствующее моему ядру?
3) Невзирая на это, я совершил пробный вброс кукушонка: подменил в /install vmlinuz и initrd.gz своими, от своего ядра. Результат был более чем ощутимый: если раньше после выбора "Установить Lubuntu" система грохалась по PAE сразу же, то сейчас она секунд 12 помешкала, подумала и только после этого выдала чёрный экран. Сначала была какая-то деятельность дисков, но через пару минут всё затихло.
4) .deb-дистрибутивы ядра я не подменял, т. к. до их установки ещё дожить надо.
sudo leafpad /etc/default/keyboard... Боже, дай мне сил :(


Автор темы
Вредятел
Сообщения: 94
Зарегистрирован: 23 янв 2012, 13:30

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение Вредятел » 06 мар 2014, 02:53

Итак, Йожин з бажин то есть Жора с бора то есть тьфу, камрады с ЛОРа дали Дельный Совет Номер Один.

При помощи вот этой замечательной штучки можно загрузиться с совершенно левого диска (ЕМНИП даже с Паппи), аккуратно всё прописать сообразно нужной версии Lubuntu и поставить оную. Плюс сырцы ядра. Плюс его там же и собрать, без PAE, ессно. И потом уже перезагрузиться.

Как-то вот так вот. Сам пока не пробовал, ни одного подопытного под рукой. Надо собрать спецом парочку говномамонтовых и на них попрактиковаться.
sudo leafpad /etc/default/keyboard... Боже, дай мне сил :(


Автор темы
Вредятел
Сообщения: 94
Зарегистрирован: 23 янв 2012, 13:30

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение Вредятел » 03 июн 2014, 00:57

Сию минуту не на чем проверить, так что спрошу. Можно ли 12.04 обновить до LTS в один шаг, минуя все 13-е? Если да, то проблема серьёзно отодвинута. Буквально до конца LTS. Потому что поставить 12.04, собрать по-быстрому ядро без PAE и дёрнуть один апдейт -- это не проблема, строго говоря.
sudo leafpad /etc/default/keyboard... Боже, дай мне сил :(


Автор темы
Вредятел
Сообщения: 94
Зарегистрирован: 23 янв 2012, 13:30

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение Вредятел » 14 авг 2014, 18:01

Проверено. Мин нет. Сработало только обновление с сидюка дистрибутива (файлик cdromupgrade), но факт есть факт: 12.04 становится 14.04.
Учитывая то, что 12.04 не требует PAE, проблема решена.
1) Поставить 12.04.
2) Поставить fake-PAE или собрать ядро под целевой камень, да хоть под 80486.
3) Накатить с нового альт-дистра апгрейд до 14.04.
4) Подновить самодельное ядро, чтобы не случился большой попадос.
5) Выполнить полное обновление.
sudo leafpad /etc/default/keyboard... Боже, дай мне сил :(


arc287
Сообщения: 2
Зарегистрирован: 22 сен 2014, 22:50

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение arc287 » 22 сен 2014, 22:59

Странно, посмотрел дату написания последнего поста - август 2014 и ничего не понял. Дело в том, что в 14.04 точно чтобы установить систему на pentium M без PAE требуется просто (как в первом посте и мечталось = в одно действие) при загрузке установочного диска или флешки указать по F6 параметр (дописать в конец загрузочной строки после стандартных туже прописанных там дефисов "--" два пробела и одно всего слово forcepae
И все! Система молча загрузится и будет уверенно грузиться всегда. Я установил на этой неделе две такие машины как по-маслу. Жалоб нет. Читайте мануал по установке в оригинале.

Аватара пользователя

adventurer
Супермодератор
Сообщения: 2847
Зарегистрирован: 15 июн 2011, 18:24

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение adventurer » 23 сен 2014, 06:04

А можно ссылку на мануал в оригинале?


arc287
Сообщения: 2
Зарегистрирован: 22 сен 2014, 22:50

Re: Установщик? ТРЕБУЕТ? РАЕ???

Сообщение arc287 » 25 сен 2014, 19:29

Installing on Pentium M laptop (with forcepae)
The ISO image will fail to boot ("This kernel requires the following features not present on the CPU: pae.") If a few lines above this text there is a warning "WARNING: PAE disabled. Use parameter 'forcepae' to enable at your own risk!", then you can boot by pressing tab at the boot screen and appending the kernel parameter "forcepae" after the "-- ".
https://help.ubuntu.com/community/EnablingPAE
Или вот ещё
The new version 14.04 LTS 'Trusty Tahr' needs no fake-PAE. Use forcepae in the standard installers
The new version 14.04 LTS 'Trusty Tahr', needs no fake-PAE to work with Pentium M and Celeron M CPUs. Instead you use the boot option forcepae and boot from the standard desktop installer and alternate installer for 32-bit systems. I think Lubuntu and Xubuntu will work well in laptops with these CPUs. Xubuntu has a medium light desktop environment and Lubuntu has an ultra light desktop environment. Try both to find what is best for you
https://help.ubuntu.com/community/Lubuntu-fake-PAE#Test


Вернуться в «Установка и настройка Lubuntu»