Не видны символы

Здесь можно задавать любые вопросы по установке и настройке Lubuntu Linux

Модератор: Vadim


Автор темы
AntonWinter
Сообщения: 3
Зарегистрирован: 10 дек 2015, 19:17

Не видны символы

#1

Сообщение AntonWinter » 18 дек 2015, 00:59

Lubuntu 15.10
Столкнулся с тем, что символы будто замазываются.И в терминале,и в меню, и в документах. Никак не пойму, как исправить. Вроде все насчет локализации загрузил , локали русские. Гугл молчит(или я плохо искал).
Изображение


Вредятел
Сообщения: 94
Зарегистрирован: 23 янв 2012, 13:30

Re: Не видны символы

#2

Сообщение Вредятел » 18 дек 2015, 01:12

Ух ты, страсти-мордасти. У меня такое было на 3dfx, но его сейчас вообще вывели из поддержки (козлы). Руками правил дрова, пересобирал, работало (дважды козлы, им делаешь, а они…) Сейчас вообще с видеодровами бардак, многое перестало работать или начало глючить (трижды козлы, «не сломалось — не чини!»).

Что за видюха, что за железо вообще? Если в терминале тоже такая беда — похоже на глюк обновления фреймбуфера. Что будет, если окно потаскать, чтобы перерисовалось?


Автор темы
AntonWinter
Сообщения: 3
Зарегистрирован: 10 дек 2015, 19:17

Re: Не видны символы

#3

Сообщение AntonWinter » 18 дек 2015, 01:19

Вредятел писал(а):Ух ты, страсти-мордасти. У меня такое было на 3dfx, но его сейчас вообще вывели из поддержки (козлы). Руками правил дрова, пересобирал, работало (дважды козлы, им делаешь, а они…) Сейчас вообще с видеодровами бардак, многое перестало работать или начало глючить (трижды козлы, «не сломалось — не чини!»).

Что за видюха, что за железо вообще? Если в терминале тоже такая беда — похоже на глюк обновления фреймбуфера. Что будет, если окно потаскать, чтобы перерисовалось?
GTX 745
Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz
16Gb DDR3 1600MHz

Самое странное - что в браузере "замазывает" адресную строку рандомно, а название терминалов ,например LXTerminal( в меню), только первые символы всегда и везде. Терминал также рандомно замазывает.
Изображение
Перетаскивание помогает,но временно

Аватара пользователя

Zozo82
Сообщения: 39
Зарегистрирован: 04 фев 2016, 22:59
Откуда: [Msk]

Re: Не видны символы

#4

Сообщение Zozo82 » 05 фев 2016, 18:32

У меня немного другая проблема:кодировка в консоли - вместо русских букв квадратики http://help.ubuntu.ru/wiki/russian_font_in_console - нашел,попробовал и не помогло...дошел до разноцветной настройки раскладок,выбрал UTF-8 и все по-старому.

Аватара пользователя

Zozo82
Сообщения: 39
Зарегистрирован: 04 фев 2016, 22:59
Откуда: [Msk]

Re: Не видны символы

#5

Сообщение Zozo82 » 05 фев 2016, 18:33

Забыл уточнить:Lubuntu 15.10 нетбук Asus x101h

Аватара пользователя

adventurer
Супермодератор
Сообщения: 3184
Зарегистрирован: 15 июн 2011, 18:24

Re: Не видны символы

#6

Сообщение adventurer » 05 фев 2016, 20:30


Аватара пользователя

Zozo82
Сообщения: 39
Зарегистрирован: 04 фев 2016, 22:59
Откуда: [Msk]

Re: Не видны символы

#7

Сообщение Zozo82 » 06 фев 2016, 01:45

Спасибо большое! Все получилось,по пути освоил редактор nano :)
СпойлерПоказать
Из Вашей ссылки:"У меня самый простой способ (ubuntu mate 15.4)
Открываем /etc/default/console-setup меняем FONTSIZE смотрим имя шрифта CODESET="Uni2" переходим в /etc/console-setup и распаковываем шрифт прописанный в конфиге (в моём случае Uni2-Fixed16.psf.gz) в эту же папку. После перезагрузки квадратики изчезают не только в консоли но и в recovery.
Вот пример моего рабочего:

ACTIVE_CONSOLES="/dev/tty[1-6]"
CHARMAP="UTF-8"
CODESET="Uni2"
FONTFACE="Fixed"
FONTSIZE="16"
VIDEOMODE=

ps: Имя шрифта,как многие уже догадались (CODESET)-(FONTFACE)(FONTSIZE).psf"
И по поводу редактирования конф.файлов:
" sudo -s
nano /что/надо/открыть.conf
<редактируем, что надо>
F2,y"

Аватара пользователя

Oleg
Сообщения: 9
Зарегистрирован: 09 янв 2018, 11:50
Контактная информация:

Не видны символы

#8

Сообщение Oleg » 16 янв 2018, 22:21

У меня на 16.04 в recovery mode вместо русских букв всё в квадратиках, хотя в самом lubuntu с кириллицей всё в порядке. Насколько я понимаю мне не нужно распаковывать Uni2-Fixed16.psf.gz и прописывать Uni2? Ведь проблема с кодировкой только в recovery mode...

Аватара пользователя

adventurer
Супермодератор
Сообщения: 3184
Зарегистрирован: 15 июн 2011, 18:24

Не видны символы

#9

Сообщение adventurer » 17 янв 2018, 06:08

Посмотрел lubuntu 16.04 и lubuntu 17.10, установленные в virtualbox - никаких квадратиков или вопросиков, всё правильно отображается. Смотрел в recovery mode.

Аватара пользователя

Oleg
Сообщения: 9
Зарегистрирован: 09 янв 2018, 11:50
Контактная информация:

Не видны символы

#10

Сообщение Oleg » 18 янв 2018, 13:24

adventurer, на 16.04 в recovery mode можете посмотреть, работает ли у вас служба console-setup? Команда:

Код: Выделить всё

sudo systemctl status console-setup
там Active: inactive (dead) или Active: active (exited)?

И ещё один вопрос, в /lib/recovery-mode/l10n.sh
ru_RU добавлен в блэклист?

Ответить