uptime: неверное количество пользователей в системе?

Модератор: Vadim


Автор темы
booBot
Сообщения: 246
Зарегистрирован: 24 июн 2015, 11:19

uptime: неверное количество пользователей в системе?

#1

Сообщение booBot » 14 ноя 2015, 11:40

После свежего старта ОС и входа в неё 1 (одного) пользователя - по login/password - попытка проверить время работы ОС с помощью утилиты uptime даёт неверные сведения о количестве пользователей, зарегистрированных в системе.
В первой консоли мне сообщают уже о двух пользователях, в каждой следующей консоли - ещё на единицу больше.

С какой стати?! Меня похакали? Ведь login/password я вводил только 1 (один) раз - значит и ОС должна считать, что число пользователей равно одному единственному.

Аватара пользователя

newerty
Сообщения: 282
Зарегистрирован: 11 окт 2015, 20:52

Re: uptime: неверное количество пользователей в системе?

#2

Сообщение newerty » 14 ноя 2015, 15:30

Ну даже не знаю, у меня все почему-то нормально.
Изображение
А команда w тоже выдает несколько пользователей? Посмотрите, какие именно пользователи у вас и скиньте посмотреть, вроде такого не должно быть.

Аватара пользователя

oqobo
Сообщения: 405
Зарегистрирован: 16 фев 2012, 21:49
Откуда: EARTH, Solar System

Re: uptime: неверное количество пользователей в системе?

#3

Сообщение oqobo » 14 ноя 2015, 15:45

Ха, у меня таже болезнь, но не чувствую дискомфорта. Скажите, доктор, а как єто может отобразиться на моем здоровье?
Изображение
lubuntu 14.04 32bit

Аватара пользователя

newerty
Сообщения: 282
Зарегистрирован: 11 окт 2015, 20:52

Re: uptime: неверное количество пользователей в системе?

#4

Сообщение newerty » 14 ноя 2015, 15:58

oqobo, а какие пользователи у вас выводятся по команде w?
p.s. У меня Lubuntu 16.04, может, в этом дело, что-то возможно исправили.


Автор темы
booBot
Сообщения: 246
Зарегистрирован: 24 июн 2015, 11:19

Re: uptime: неверное количество пользователей в системе?

#5

Сообщение booBot » 14 ноя 2015, 16:37

У меня - 14.04, как в подписи, w видит один и тот же %username%, но на разных консолях. И, соответственно, считает несколькими пользователями (по числу открытых консолей), хотя from у них всех один и тот же == :0.

Аватара пользователя

oqobo
Сообщения: 405
Зарегистрирован: 16 фев 2012, 21:49
Откуда: EARTH, Solar System

Re: uptime: неверное количество пользователей в системе?

#6

Сообщение oqobo » 14 ноя 2015, 17:16

Изображение

Сначала - возврат командьі W при открьітьіх окнах терминала (как на предьідущем скрине), а второй вьівод командьі после закрьітия остальньіх окон терминала.

Аватара пользователя

newerty
Сообщения: 282
Зарегистрирован: 11 окт 2015, 20:52

Re: uptime: неверное количество пользователей в системе?

#7

Сообщение newerty » 14 ноя 2015, 17:36

Я так подозреваю, что в новых версиях Lubuntu убрали вывод пользователей из т.н. pts-консолей.
Дайте вывод [mono]uptime -V && w -V && who --version[/mono].
 Вот что у меня
uptime from procps-ng 3.3.9
w from procps-ng 3.3.9
who (GNU coreutils) 8.23

Если версия старая, возможно, нужно обновить procps-ng и gnu-coreutils.


Автор темы
booBot
Сообщения: 246
Зарегистрирован: 24 июн 2015, 11:19

Re: uptime: неверное количество пользователей в системе?

#8

Сообщение booBot » 14 ноя 2015, 17:56

Версии uptime и w - как у вас, версия who == 8.21

Аватара пользователя

newerty
Сообщения: 282
Зарегистрирован: 11 окт 2015, 20:52

Re: uptime: неверное количество пользователей в системе?

#9

Сообщение newerty » 14 ноя 2015, 18:37

Тогда проблема где-то глубже в системе. Может, в системных библиотеках, может, еще где.

Аватара пользователя

oqobo
Сообщения: 405
Зарегистрирован: 16 фев 2012, 21:49
Откуда: EARTH, Solar System

Re: uptime: неверное количество пользователей в системе?

#10

Сообщение oqobo » 14 ноя 2015, 19:43

Код: Выделить всё

uptime from procps-ng 3.3.9
w from procps-ng 3.3.9
who (GNU coreutils) 8.21


Вернуться в «Общетематические вопросы по Linux»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость