отключить xserver (работа в командном режиме)

Модератор: Vadim

Ответить

Автор темы
MishkaS
Сообщения: 4
Зарегистрирован: 05 сен 2016, 10:07

отключить xserver (работа в командном режиме)

#1

Сообщение MishkaS » 05 сен 2016, 10:19

Доброго дня.
я очень слабо разбираюсь в линуксах.
у меня есть малинка пи и на ней прям в настройках отключается автозапуск оболочки визуальной. она мне в общем то совсем не нужна. (но тут raspbian-jessie)
и есть апельсинка, на ней Lubuntu_1404_For_OrangePiPC_v0_8_0_, и не могу найти в настройках где отрубить xserver(я правильно его называю?)
есть инструкции в инете как на убунту отключить, но убунту сейчас чёто не качается с orangepi.org
а вот lubuntu скачалась и запустилась.
в общем то мне нужна любая ось, поддерживаемая, orange pi pc, и где можно пакеты устанавливать через apt-get. :%) потому что очень слаб в linux может подскажете? :)

Аватара пользователя

adventurer
Супермодератор
Сообщения: 2968
Зарегистрирован: 15 июн 2011, 18:24

Re: отключить xserver (работа в командном режиме)

#2

Сообщение adventurer » 05 сен 2016, 12:52

Приведите ссылку на инструкцию в ubuntu и, возможно, Вам посоветуют как её адаптировать к lubuntu.


Автор темы
MishkaS
Сообщения: 4
Зарегистрирован: 05 сен 2016, 10:07

Re: отключить xserver (работа в командном режиме)

#3

Сообщение MishkaS » 05 сен 2016, 14:28

советы на форумах похожи, вот например с сайта какого-то https://oioki.ru/2011/06/kak-otklyuchit ... er-ubuntu/
отключить xserverПоказать
В Ubuntu используется система инициализации под названием «Upstart». Если вы пробовали связываться с update-rc и замечали, что выключение /etc/init.d/gdm не работает, то теперь вы поймете почему. Конечно, можно выполнить:

/etc/init.d/gdm stop

/etc/init/gdm.conf:
# Нужно закомментировать следующее:
#start on (filesystem
# and started hal
# and tty-device-added KERNEL=tty7
# and (graphics-device-added or stopped udevtrigger))
#stop on runlevel [016]

Обратите внимание, что я закомментировал строки start on и stop on. Теперь вы сможете запускать X-сервер и графический менеджер с помощью /etc/init.d/gdm start (даже более правильно — initctl start gdm), но автоматически при запуске компьютера он стартовать не будет.
а я у себя не смог найти никакого gdm.conf
возможно другая оболочка используется?



vdo
Сообщения: 89
Зарегистрирован: 28 янв 2015, 13:36

Re: отключить xserver (работа в командном режиме)

#5

Сообщение vdo » 06 сен 2016, 19:16

Какая-то странная инструкция :)
Вам надо пойти в каталог
/etc/init/
без .d

И там найти файл
lightdm.conf

В этом файле есть строчка типа
"start on" и далее
вот и комментировать надо от этой строчки до строчки
"stop on"

Зачем в инструкции комментируют и саму строчку "stop on" я не понял...


Автор темы
MishkaS
Сообщения: 4
Зарегистрирован: 05 сен 2016, 10:07

Re: отключить xserver (работа в командном режиме)

#6

Сообщение MishkaS » 06 сен 2016, 22:14

Большое спасибо за помощь и хочу рассказать о пробах своих.
при переименовании файла /etc/init/lightdm.conf в /etc/init/lightdm_.conf
либо комментировании между заголовками start on и stop on, либо комментировании вместе с заголовками происходит следующее:
просто висят строки и через пару минут появляются новые, возможно что при запуске граф.оболочки не видно просто этих строк. т.к. при подключении по SSH этого же не видно и можно что угодно запускать.
просто висит это:Показать
Изображение
затем когда нажимаешь на стрелки клавы появляется следующий экран: (это значит что перед lightdm запускается заставка загрузки ОСи, правильно? и её тоже наверно можно где-то вырубить? или всё-таки это неправильно?)
если нажимать вверх и внизПоказать
Изображение
Изображение
если нажать ctrl+alt+f1 открывается нормальная командная строка.
ctrl+alt+f1Показать
Изображение
возможно ещё то что у меня не заканчивается нормально загрузка ОСи другая проблема, а не в lightdm.
но я ничего ещё не делал чтобы испортить загрузку :) я только залил образ на флешку, да установил mc... ну и, естественно, пробовал немножко менять lightdm.conf

ещё из ссылки на хелп, в 4 посте:
Также можно просто исправить файл xorg.conf, добавив в него секцию:
Section "ServerFlags"
Option "DontZap" "false"
EndSection
сейчас попробую запихать такое в, соответственно, lightdm.conf, но надежда небольшая что сработает ))
есть ещё идеи, товарищи, linux-гуру?


Автор темы
MishkaS
Сообщения: 4
Зарегистрирован: 05 сен 2016, 10:07

Re: отключить xserver (работа в командном режиме)

#7

Сообщение MishkaS » 06 сен 2016, 22:28

попробовал добавить
Также можно просто исправить файл xorg.conf, добавив в него секцию:
Section "ServerFlags"
Option "DontZap" "false"
EndSection
результат одинаковый с, допустим, переименованием файла .conf

так понимаю у меня ещё проблема со SPOOLER`ом
ну и как то по правильному надо, наверно, ещё отрубить визуальный прогрессбар загрузки.
щас полазаю по инету. :) где то я о нём уже читал..


vdo
Сообщения: 89
Зарегистрирован: 28 янв 2015, 13:36

Re: отключить xserver (работа в командном режиме)

#8

Сообщение vdo » 08 сен 2016, 01:27

MishkaS писал(а): просто висят строки и через пару минут появляются новые, возможно что при запуске граф.оболочки не видно просто этих строк. т.к. при подключении по SSH этого же не видно и можно что угодно запускать.
Ну дак пускай себе висят. Иксы же выключились? Т.е. что хотели получилось или что-то другое хотели? :)
MishkaS писал(а):
ещё из ссылки на хелп, в 4 посте:
Также можно просто исправить файл xorg.conf, добавив в него секцию:
Section "ServerFlags"
Option "DontZap" "false"
EndSection
сейчас попробую запихать такое в, соответственно, lightdm.conf, но надежда небольшая что сработает ))
есть ещё идеи, товарищи, linux-гуру?
Это надо добавлять в файл /etc/X11/xorg.conf, а не в /etc/init/lightdm.conf
MishkaS писал(а): ну и как то по правильному надо, наверно, ещё отрубить визуальный прогрессбар загрузки.
Если он мешает, то вырубать в
/boot/grub/grub.cfg
Там найти что-то типа
linux /boot/vmlinuz-4.4.0-31-generic root=UUID=aee3...............288 ro quiet splash бла-бла-бла
и удалить
quiet splash
т.е. чтоб было
linux /boot/vmlinuz-4.4.0-31-generic root=UUID=aee3...............288 ro бла-бла-бла
Но с этим файлом аккуратнее. Если накосячить, то можно потом и не загрузиться ;)

А чтоб при обновлении ядра оно не вернулось надо править еще файл
/etc/default/grub
Чтоб в строке
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash бла-бла-бла"
не было quiet splash

Ответить