Не работает вывод видео через xv

Задаем вопросы по сборке
Ответить

Автор темы
Monstrman
Сообщения: 13
Зарегистрирован: 26 мар 2011, 09:00

Не работает вывод видео через xv

#1

Сообщение Monstrman » 26 мар 2011, 09:19

при проигрывании фильма в полноэкране, пригодилься бы вывод через xv, но когда его выбираешь - видео исчезает, как бы его добавить, это самый производительный вывод даже по сравнению с х11. Мой рабочий компьютер довольно слабый и видео на х11 идет не гладко а с маленькими раздражающими рывочками. я говорю а полноэкране.

Аватара пользователя

Lubrox
Сообщения: 1577
Зарегистрирован: 13 фев 2011, 22:52

Re: Не работает вывод видео через xv

#2

Сообщение Lubrox » 26 мар 2011, 12:09

gstreamer-properties

Поставь vlc (свои кодеки может поможет) и smplayer (этот быстрее) там можно выбрать
Включи пропуск кадров в проигрывателе

Аватара пользователя

keha
Администратор
Сообщения: 860
Зарегистрирован: 16 дек 2010, 18:11
Откуда: Красноярск

Re: Не работает вывод видео через xv

#3

Сообщение keha » 26 мар 2011, 16:18

Monstrman - телепаты все в отпуске...а вы не знали? так вот...
Если хочется привлечь простых смертных, то ответьте на вопросы:
1) какая версия Lubuntu;
2) Какой проигрыватель используете и какой версии;
3) есть ли варианты, когда эти файлы воспроизводились без проблем? (в MS Win, др дистрибутиве Linux, и т.п.)


Автор темы
Monstrman
Сообщения: 13
Зарегистрирован: 26 мар 2011, 09:00

Re: Не работает вывод видео через xv

#4

Сообщение Monstrman » 26 мар 2011, 19:30

keha писал(а):Monstrman - телепаты все в отпуске...а вы не знали? так вот...
Если хочется привлечь простых смертных, то ответьте на вопросы:
1) какая версия Lubuntu;
2) Какой проигрыватель используете и какой версии;
3) есть ли варианты, когда эти файлы воспроизводились без проблем? (в MS Win, др дистрибутиве Linux, и т.п.)
keha писал(а):Monstrman - телепаты все в отпуске...а вы не знали? так вот...
версия самая, что ни на есть ваша, последняя v7, естественно плеер там гном плеер, сам я там ниче не менял, файлы воспроизводились без проблем на рунту офис про, рунту 9.04, виндовоз естественно, на рунту лайт теже самые тормоза, только плеер там влц и тоже вывод через xv там видео не показывает.

Аватара пользователя

Lubrox
Сообщения: 1577
Зарегистрирован: 13 фев 2011, 22:52

Re: Не работает вывод видео через xv

#5

Сообщение Lubrox » 26 мар 2011, 19:48

у тебя вообще lubuntu-restricted стоят?
видюха какая и драйвер?


Автор темы
Monstrman
Сообщения: 13
Зарегистрирован: 26 мар 2011, 09:00

Re: Не работает вывод видео через xv

#6

Сообщение Monstrman » 26 мар 2011, 21:35

на счет lubuntu-restricted не знаю
у меня сборка v7 с данного сайта. Видюха джифорс2, проприетарных дров не ставил, скорее всего wise стоит

Аватара пользователя

keha
Администратор
Сообщения: 860
Зарегистрирован: 16 дек 2010, 18:11
Откуда: Красноярск

Re: Не работает вывод видео через xv

#7

Сообщение keha » 27 мар 2011, 05:46

Поставьте vlc и не морочьте людям голову ;) Я хоть и воткнул гном-плеер, но обкатать у меня его особых возможностей не было. Обычно это делают тестеры, но таковых не было обнаружено.

Lubrox - в 10.04 такого пакета не существует

PS в мае будет новая сборка на 11.04....

Аватара пользователя

Lubrox
Сообщения: 1577
Зарегистрирован: 13 фев 2011, 22:52

Re: Не работает вывод видео через xv

#8

Сообщение Lubrox » 27 мар 2011, 12:18

В 10.10 ещё можно выбрать kubuntu-restricted и ubuntu-restricted, а стоят именно кубунтовские пакеты.


ant
Сообщения: 9
Зарегистрирован: 11 ноя 2011, 16:27

Re: Не работает вывод видео через xv

#9

Сообщение ant » 11 ноя 2011, 16:41

Меня тоже напрягала эта проблема. Но она решилась когда я сделал следующий файл:

Код: Выделить всё

$ cat /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
    Identifier "old intel stuff"
    Driver "intel"
    Option "LinearAlloc" "6144"
    Option "Shadow" "True"
    Option "DRI" "True" #"False"
 EndSection
(Настройки эти я взял из сайта арч вики)

Я не очень обознан в линуксах. Но гугл показал, что именно строчка Option "LinearAlloc" "6144" помогает для интеловских встроенных видеокарт.

Код: Выделить всё

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
Но меня продолжает напрягать проблема с выключением экрана. Я отключил xscreensaver, xfce-power-manager, но монитор все ровно отключается. Каждые 10 минут оно должно выключиться.

Ответить