Страница 4 из 4

Re: Ждущий режим

Добавлено: 22 янв 2017, 22:06
hohlov_jurii
Заработало, тестирую. Установил ядро linux-headers-3.19.8-991-generic_3.19.8-991.201506100404_i386.deb, теперь вот вопрос, а что по поводу обновлений, не обновляться что-ли? Ведь ядро автоматом обновиться. Как дальше быть?

Re: Ждущий режим

Добавлено: 22 янв 2017, 22:11
denkin
можно зафиксировать версию любого пакета, в том числе и ядра, защитив от обновлений. Например в синаптике.

Re: Ждущий режим

Добавлено: 22 янв 2017, 22:25
hohlov_jurii
но обновляться то нужно, или нет? В целях безопасности?

Re: Ждущий режим

Добавлено: 23 янв 2017, 13:29
aleks@
hohlov_jurii писал(а):Заработало, тестирую. Установил ядро linux-headers-3.19.8-991-generic_3.19.8-991.201506100404_i386.deb, теперь вот вопрос, а что по поводу обновлений, не обновляться что-ли? Ведь ядро автоматом обновиться. Как дальше быть?
ядра 3.19.0-...... обновляются так же как и 4.4.0...
Если посмотреть в /boot, то видно какие ядра качались при обновлениях раньше, у меня их очень много накопилось, я их не удаляю. При обновлении не ставьте автоматически то, что предлагается а выбирайте и ставьте вручную. При обновлении приходят как 4.4.0 .... так и 3.19.0.

Re: Ждущий режим

Добавлено: 23 янв 2017, 22:09
denkin
aleks@, фигня только в том, что grub автоматом назначит загрузку по дефолту с самой свежей версией ядра.
hohlov_jurii, а какая версия ядра в системе? Обновляться 3.19 автоматически будет только если установить специальные пакеты с заголовками, эти кажется:
linux-headers-generic linux-generic linux-image-generic
для вашей версии ядра

Re: Ждущий режим

Добавлено: 24 янв 2017, 01:57
aleks@
denkin писал(а):aleks@, фигня только в том, что grub автоматом назначит загрузку по дефолту с самой свежей версией ядра.
Юрию остаётся только проверять при обновлении чтобы ставилось ядро 3.19, а 4.4. не устанавливать.
Если вдруг появится проблемное ядро 3.19 , то придётся загружаться со старого ядра и удалять новое. И так делать пока при обновлении не появится "рабочее" ядро. У меня у друга такая проблема, когда при обновлении появляется проблемное ядро, то приходится делать ему откат на старое, а новое удалять.

Re: Ждущий режим

Добавлено: 24 янв 2017, 15:45
hohlov_jurii
Друзья спасибо огромное за помощь. Я четыре месяца бился над данной проблемой. Куда только и не писал. Что только и не делал. И сносил систему, и опять ставил, и на английский сайт писал, и grub правил, файл подкачки убирал, затем опять ставил, запускал систему со свободными драйвера, обновлял свою видюху, ставил чистую ubuntu server в поисках проблемы.

Re: Ждущий режим

Добавлено: 24 янв 2017, 18:18
abml
А можно спросить кое-что чуть в сторону, поскольку основной вопрос для меня интересен. Могу и новую тему "сварганить".
Я сейчас дома, где Хуб-та, но на работе Луб-та с тем же номером -- 12.04.
Итак, когда устанавливаешь 12.04.0 (0 - условно), то ядро = 3.2. Затем я годами обновлялся по правилам (ядра тоже обновлял). Дожил до Хуб-ту 12.04.5, а у ядра менялось лишь последнее число; сейчас ядро = 3.2.0-119. Повторяю, что вопрос относится и к Лубунте на работе; там нет номера 12.04.5, но в остальном все то же самое, т.к., насколько я понимаю, ядра "идут от самой Убунты". Так вот, в Вики сказано, что в конце поддержки ядро будет не 3.2, а 3.13. Почему же у меня все ядра 3.2, хотя я их обновлял немеренное число раз (они приходили автоматом, по стандартной схеме). Может быть 3.2.0-119 это тоже самое (каким-то образом, но каким?), что и 3.13, которое должно быть "по закону". Иначе: если бы я скачал iso для 12.04.5, то получил бы ядро 3.13. А если я как законопослушный гражданин делаю все постепенно (несколько лет), то живу с 3.2. ПОЧЕМУ?
Пож-та, поясните!

Re: Ждущий режим

Добавлено: 25 янв 2017, 14:02
hohlov_jurii
Я не могу ответить на этот вопрос, может кто другой подскажет?

Re: Ждущий режим

Добавлено: 25 янв 2017, 14:40
zhart
Может кто и подскажет в рамках другой темы, а здесь это оффтоп.