[решено] Ошибка при установке deb пакетов

Ответить

Автор темы
js
Сообщения: 6
Зарегистрирован: 14 ноя 2011, 12:47

[решено] Ошибка при установке deb пакетов

#1

Сообщение js » 29 июл 2013, 08:19

Вот сообщение:

Код: Выделить всё

Предварительная настройка пакетов ...
dpkg: ошибка: анализ файла «/var/lib/dpkg/available» около строки 35938 пакета «time»:
 ошибка в строке Version «tion of boot loaders which operates off Linux ext2/3/4 or
 btrfs filesystems, MS-DOS FAT filesystems, network servers using PXE firmware,
 or from CD-ROMs.
 .
 This package depends on the package with the graphical bootloader theme
 for the matching »: в строке версии есть пробелы
E: Sub-process /usr/bin/dpkg returned an error code (2)
Чего я сломал?


anyr
Сообщения: 33
Зарегистрирован: 08 май 2012, 13:31

Re: Ошибка при установке deb пакетов

#2

Сообщение anyr » 29 июл 2013, 09:45

js писал(а):Вот сообщение:

Код: Выделить всё

 This package depends on the package with the graphical bootloader theme
 for the matching)
Чего я сломал?
А что ставите такое? Может в зависимостях "другие" названия пакетов. Сейчас мне трудно представить, чтобы в репозитории совсем отсутствовали графические темы для загрузчика.


Автор темы
js
Сообщения: 6
Зарегистрирован: 14 ноя 2011, 12:47

Re: Ошибка при установке deb пакетов

#3

Сообщение js » 29 июл 2013, 12:03

Сообщение появляется при попытке обновиться, при установке syslinux-themes-debian-wheezy, apt-fast, localepurge и ещё с десяток пакетов, которые я пробовал устанавливать. Причина явно не в пакетах и их зависимостях


Автор темы
js
Сообщения: 6
Зарегистрирован: 14 ноя 2011, 12:47

Re: Ошибка при установке deb пакетов

#4

Сообщение js » 29 июл 2013, 18:54

Ура, решил! dpkg поломался. Варианты решения есть здесь http://kubuntu.ru/node/5124
Мне помогла замена var/lib/dpkg/available его бэкапом (available_old)

ЗЫ. Не знаю, как поставить пометку "решено".

Ответить