нет звука

Здесь можно задавать любые вопросы по установке и настройке Lubuntu Linux

Модератор: Vadim


ternovvan
Сообщения: 13
Зарегистрирован: 22 дек 2015, 10:45

Re: нет звука

#111

Сообщение ternovvan » 12 мар 2021, 09:17

В Lubuntu 20.10 пропадает звук. Возникет после загрузки красный кружок с восклицательным знаком в нём. После Переустановки ALSA и PulseAudio восстанавливается, После выключения опять пропадает.


PPeterr
Сообщения: 2
Зарегистрирован: 25 май 2021, 20:23

Re: нет звука

#112

Сообщение PPeterr » 25 май 2021, 21:11

Здравствуйте.
У меня вопрос не совсем по теме названия ветки, но чем-то схожий.
Некоторое время назад я установил в нетбук Lubuntu 14.04 с целью слушать музыку. Я подключил к нетбуку внешнюю USB звуковую карту M-Audio "Transit" и хотел весь звуковой поток воспроизводить только через неё. Микшер в той сборке Lubuntu по умолчанию "alsamixer" я выбираю там внешнюю звуковую карточку и всё хорошо - отлично слушаю музыку в "Audacious".
Но затем столкнулся с проблемой - штатный браузер Firefox не выводил звук на мою внешнюю звуковую карту, а только на динамики нетбука. Это меня не устраивало. Я попытался заменить браузер - установил "Chromium" - но и там звук шёл только через штатные динамики нетбука, несмотря на то, что в микшере "alsamixer" я выбирал звуковую карту - внешнюю, USB.
В итоге, когда я установил себе дополнительно плеер "PulseAudio" и микшер "pavucontrol" - звук стал выводиться через внешнюю USB карту, как я и хотел.
По различным причинам, ту систему Lubuntu 14.04 я на данный момент удалил с нетбука. И установил заново её же. Сейчас у меня чистая система. И я хочу сделать так, чтобы звук в браузерах у меня выводился на внешнюю звуковую карту, но без установок "PulseAudio" и "pavucontrol".
То есть - я хочу чтобы у меня остался "alsamixer" но при этом - получилось бы звук в браузерах вывести через внешнюю звуковую USB карту (в Audacious при этом звук без проблем выводится через неё). Подскажите пожалуйста, как это сделать?


PPeterr
Сообщения: 2
Зарегистрирован: 25 май 2021, 20:23

Re: нет звука

#113

Сообщение PPeterr » 25 май 2021, 23:25

Похоже, я сам смог найти решение по своему вопросу. Как я понял - меняется звуковая карта системы по умолчанию. Если ранее у меня в alsamixer надо было выбирать внешнюю звуковую карту через F6, то теперь она там появляется сразу при загрузке, в строчке "- по умолчанию".
А делается это так:
1. В терминале вводится строка "sudo nano /etc/asound.conf" после этого Enter.
2. Открывается текстовый редактор, в нём пишем две строки:
defaults.ctl.card 1
defaults.pcm.card 1
3. Сохранить
4. Закрыть
И после перезагрузки, моя внешняя USB звуковая карта - стала по умолчанию в системе и теперь в браузере звук идёт через неё.

Ответить