Обновление программного обеспечения Тема решена

Здесь можно задавать любые вопросы по установке и настройке Lubuntu Linux

Модератор: Vadim


Автор темы
krapov
Сообщения: 12
Зарегистрирован: 03 янв 2018, 00:05

Обновление программного обеспечения

#1

Сообщение krapov » 04 фев 2019, 20:45

Стоит Lubuntu 18.04.1 LTS. Просится обновление приложений и безопасности на комьпютер, а обновиться не может. Пишет проблемы с интернет соединением хотя я пишу сюда и интернет есть. Объясните мне чайнику, что надо сделать. Раньше на старых версиях убунты таких вопросов не возникало, сейчас куча серверов для обновления, какой ни выбираю идет сброс обновления.


MikeRM
Сообщения: 61
Зарегистрирован: 19 окт 2018, 19:53

Re: обновления програмного обеспичения

#2

Сообщение MikeRM » 04 фев 2019, 21:15

Откуда куча серверов? Lubuntu - производная от Debian и всю жизнь обновлялась через apt.
Покажите вывод:

Код: Выделить всё

sudo apt update
sudo apt list --upgradable


Автор темы
krapov
Сообщения: 12
Зарегистрирован: 03 янв 2018, 00:05

Re: обновления програмного обеспичения

#3

Сообщение krapov » 04 фев 2019, 21:36

СпойлерПоказать
Игн:1 cdrom://Lubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) bionic InRelease
Ошк:2 cdrom://Lubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) bionic Release
Пожалуйста, используйте apt-cdrom, чтобы APT смог распознать данный CD. apt-get update не используется для добавления нового CD
Сущ:3 http://ua.archive.ubuntu.com/ubuntu bionic InRelease
Сущ:4 http://ua.archive.ubuntu.com/ubuntu bionic-updates InRelease
Сущ:5 http://ua.archive.ubuntu.com/ubuntu bionic-backports InRelease
Сущ:6 http://ua.archive.ubuntu.com/ubuntu bionic-security InRelease
Пол:7 https://deb.opera.com/opera-stable stable InRelease [2.591 B]
E: Репозиторий «https://deb.opera.com/opera-stable stable InRelease» изменил значение поля «Origin» с «Opera Software ASA» на «Opera Software AS»
N: Требуется явное подтверждение, прежде чем можно будет обновить данный репозиторий. Дополнительную информацию смотрите в справочной странице apt-secure(8).
Вы хотите принять эти изменения и продолжить обновление из этого репозитория? [д/Н] d
Чтение списков пакетов… Готово
E: Репозиторий «cdrom://Lubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) bionic Release» не содержит файла Release.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, и поэтому по умолчанию он отключён.
N: Смотрите справочную страницу apt-secure(8) о создании репозитория и настройке пользователя.


Автор темы
krapov
Сообщения: 12
Зарегистрирован: 03 янв 2018, 00:05

Re: обновления програмного обеспичения

#4

Сообщение krapov » 04 фев 2019, 21:41

СпойлерПоказать
Вывод списка… Готово
apparmor/bionic-updates,bionic-security 2.12-4ubuntu5.1 amd64 [может быть обновлён с: 2.12-4ubuntu5]
apport/bionic-updates,bionic-updates 2.20.9-0ubuntu7.5 all [может быть обновлён с: 2.20.9-0ubuntu7.3]
apport-gtk/bionic-updates,bionic-updates 2.20.9-0ubuntu7.5 all [может быть обновлён с: 2.20.9-0ubuntu7.3]
appstream/bionic-updates 0.12.0-3ubuntu1 amd64 [может быть обновлён с: 0.12.0-3]
apt/bionic-updates 1.6.8 amd64 [может быть обновлён с: 1.6.3ubuntu0.1]
apt-config-icons/bionic-updates,bionic-updates 0.12.0-3ubuntu1 all [может быть обновлён с: 0.12.0-3]
apt-utils/bionic-updates 1.6.8 amd64 [может быть обновлён с: 1.6.3ubuntu0.1]
avahi-daemon/bionic-updates,bionic-security 0.7-3.1ubuntu1.2 amd64 [может быть обновлён с: 0.7-3.1ubuntu1.1]
bind9-host/bionic-updates 1:9.11.3+dfsg-1ubuntu1.3 amd64 [может быть обновлён с: 1:9.11.3+dfsg-1ubuntu1.1]
bsdutils/bionic-updates 1:2.31.1-0.4ubuntu3.3 amd64 [может быть обновлён с: 1:2.31.1-0.4ubuntu3.1]
cpp/bionic-updates 4:7.3.0-3ubuntu2.1 amd64 [может быть обновлён с: 4:7.3.0-3ubuntu2]
cpp-7/bionic-updates 7.3.0-27ubuntu1~18.04 amd64 [может быть обновлён с: 7.3.0-16ubuntu3]
cups/bionic-updates 2.2.7-1ubuntu2.3 amd64 [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-bsd/bionic-updates 2.2.7-1ubuntu2.3 amd64 [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-client/bionic-updates 2.2.7-1ubuntu2.3 amd64 [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-common/bionic-updates,bionic-updates 2.2.7-1ubuntu2.3 all [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-core-drivers/bionic-updates 2.2.7-1ubuntu2.3 amd64 [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-daemon/bionic-updates 2.2.7-1ubuntu2.3 amd64 [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-ipp-utils/bionic-updates 2.2.7-1ubuntu2.3 amd64 [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-ppdc/bionic-updates 2.2.7-1ubuntu2.3 amd64 [может быть обновлён с: 2.2.7-1ubuntu2.1]
cups-server-common/bionic-updates,bionic-updates 2.2.7-1ubuntu2.3 all [может быть обновлён с: 2.2.7-1ubuntu2.1]
desktop-file-utils/bionic-updates 0.23-1ubuntu3.18.04.2 amd64 [может быть обновлён с: 0.23-1ubuntu3.18.04.1]
dirmngr/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
distro-info-data/bionic-updates,bionic-updates,bionic-security,bionic-security 0.37ubuntu0.2 all [может быть обновлён с: 0.37ubuntu0.1]
dnsutils/bionic-updates 1:9.11.3+dfsg-1ubuntu1.3 amd64 [может быть обновлён с: 1:9.11.3+dfsg-1ubuntu1.1]
dpkg/bionic-updates 1.19.0.5ubuntu2.1 amd64 [может быть обновлён с: 1.19.0.5ubuntu2]
e2fsprogs/bionic-updates 1.44.1-1ubuntu1 amd64 [может быть обновлён с: 1.44.1-1]
evince/bionic-updates 3.28.4-0ubuntu1 amd64 [может быть обновлён с: 3.28.2-1]
evince-common/bionic-updates,bionic-updates 3.28.4-0ubuntu1 all [может быть обновлён с: 3.28.2-1]
evolution-data-server-common/bionic-updates,bionic-updates 3.28.5-0ubuntu0.18.04.1 all [может быть обновлён с: 3.28.3-0ubuntu0.18.04.1]
fdisk/bionic-updates 2.31.1-0.4ubuntu3.3 amd64 [может быть обновлён с: 2.31.1-0.4ubuntu3.1]
firefox/bionic-updates,bionic-security 65.0+build2-0ubuntu0.18.04.1 amd64 [может быть обновлён с: 62.0+build2-0ubuntu0.18.04.3]
firefox-locale-en/bionic-updates,bionic-security 65.0+build2-0ubuntu0.18.04.1 amd64 [может быть обновлён с: 62.0+build2-0ubuntu0.18.04.3]
firefox-locale-ru/bionic-updates,bionic-security 65.0+build2-0ubuntu0.18.04.1 amd64 [может быть обновлён с: 62.0+build2-0ubuntu0.18.04.3]
flashplugin-installer/bionic-updates,bionic-security 32.0.0.114ubuntu0.18.04.1 amd64 [может быть обновлён с: 30.0.0.154ubuntu0.18.04.1]
fonts-noto-color-emoji/bionic-updates,bionic-updates 0~20180810-0ubuntu1 all [может быть обновлён с: 0~20180424-0ubuntu1]
friendly-recovery/bionic-updates,bionic-updates 0.2.38ubuntu1 all [может быть обновлён с: 0.2.38]
fwupd/bionic-updates 1.0.9-0ubuntu2 amd64 [может быть обновлён с: 1.0.6-2]
gcc-7-base/bionic-updates 7.3.0-27ubuntu1~18.04 amd64 [может быть обновлён с: 7.3.0-16ubuntu3]
gcc-8-base/bionic-updates 8.2.0-1ubuntu2~18.04 amd64 [может быть обновлён с: 8-20180414-1ubuntu2]
gettext-base/bionic-updates,bionic-security 0.19.8.1-6ubuntu0.1 amd64 [может быть обновлён с: 0.19.8.1-6]
ghostscript/bionic-updates,bionic-security 9.26~dfsg+0-0ubuntu0.18.04.4 amd64 [может быть обновлён с: 9.22~dfsg+1-0ubuntu1.1]
ghostscript-x/bionic-updates,bionic-security 9.26~dfsg+0-0ubuntu0.18.04.4 amd64 [может быть обновлён с: 9.22~dfsg+1-0ubuntu1.1]
gir1.2-javascriptcoregtk-4.0/bionic-updates,bionic-security 2.22.5-0ubuntu0.18.04.1 amd64 [может быть обновлён с: 2.20.5-0ubuntu0.18.04.1]
gir1.2-packagekitglib-1.0/bionic-updates 1.1.9-1ubuntu2.18.04.4 amd64 [может быть обновлён с: 1.1.9-1ubuntu2.18.04.1]
gir1.2-polkit-1.0/bionic-updates,bionic-security 0.105-20ubuntu0.18.04.4 amd64 [может быть обновлён с: 0.105-20ubuntu0.18.04.1]
gir1.2-snapd-1/bionic-updates 1.43-0ubuntu0.18.04.1 amd64 [может быть обновлён с: 1.41-0ubuntu0.18.04.1]
gir1.2-udisks-2.0/bionic-updates,bionic-security 2.7.6-3ubuntu0.2 amd64 [может быть обновлён с: 2.7.6-3ubuntu0.1]
gir1.2-webkit2-4.0/bionic-updates,bionic-security 2.22.5-0ubuntu0.18.04.1 amd64 [может быть обновлён с: 2.20.5-0ubuntu0.18.04.1]
gnome-desktop3-data/bionic-updates,bionic-updates,bionic-security,bionic-security 3.28.2-0ubuntu1.2 all [может быть обновлён с: 3.28.2-0ubuntu1]
gnome-software/bionic-updates 3.28.1-0ubuntu4.18.04.8 amd64 [может быть обновлён с: 3.28.1-0ubuntu4.18.04.3]
gnome-software-common/bionic-updates,bionic-updates 3.28.1-0ubuntu4.18.04.8 all [может быть обновлён с: 3.28.1-0ubuntu4.18.04.3]
gnupg/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gnupg-l10n/bionic-updates,bionic-updates,bionic-security,bionic-security 2.2.4-1ubuntu1.2 all [может быть обновлён с: 2.2.4-1ubuntu1.1]
gnupg-utils/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gpg/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gpg-agent/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gpg-wks-client/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gpg-wks-server/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gpgconf/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gpgsm/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
gpgv/bionic-updates,bionic-security 2.2.4-1ubuntu1.2 amd64 [может быть обновлён с: 2.2.4-1ubuntu1.1]
grub-common/bionic-updates 2.02-2ubuntu8.10 amd64 [может быть обновлён с: 2.02-2ubuntu8.4]
grub-pc/bionic-updates 2.02-2ubuntu8.10 amd64 [может быть обновлён с: 2.02-2ubuntu8.4]
grub-pc-bin/bionic-updates 2.02-2ubuntu8.10 amd64 [может быть обновлён с: 2.02-2ubuntu8.4]
grub2-common/bionic-updates 2.02-2ubuntu8.10 amd64 [может быть обновлён с: 2.02-2ubuntu8.4]
gvfs/bionic-updates 1.36.1-0ubuntu1.2 amd64 [может быть обновлён с: 1.36.1-0ubuntu1.1]
gvfs-backends/bionic-updates 1.36.1-0ubuntu1.2 amd64 [может быть обновлён с: 1.36.1-0ubuntu1.1]
gvfs-common/bionic-updates,bionic-updates 1.36.1-0ubuntu1.2 all [может быть обновлён с: 1.36.1-0ubuntu1.1]
gvfs-daemons/bionic-updates 1.36.1-0ubuntu1.2 amd64 [может быть обновлён с: 1.36.1-0ubuntu1.1]
gvfs-fuse/bionic-updates 1.36.1-0ubuntu1.2 amd64 [может быть обновлён с: 1.36.1-0ubuntu1.1]
gvfs-libs/bionic-updates 1.36.1-0ubuntu1.2 amd64 [может быть обновлён с: 1.36.1-0ubuntu1.1]
initramfs-tools/bionic-updates,bionic-updates,bionic-security,bionic-security 0.130ubuntu3.6 all [может быть обновлён с: 0.130ubuntu3.1]
initramfs-tools-bin/bionic-updates,bionic-security 0.130ubuntu3.6 amd64 [может быть обновлён с: 0.130ubuntu3.1]
initramfs-tools-core/bionic-updates,bionic-updates,bionic-security,bionic-security 0.130ubuntu3.6 all [может быть обновлён с: 0.130ubuntu3.1]
irqbalance/bionic-updates 1.3.0-0.1ubuntu0.18.04.1 amd64 [может быть обновлён с: 1.3.0-0.1]
kmod/bionic-updates 24-1ubuntu3.2 amd64 [может быть обновлён с: 24-1ubuntu3]
krb5-locales/bionic-updates,bionic-updates,bionic-security,bionic-security 1.16-2ubuntu0.1 all [может быть обновлён с: 1.16-2build1]
libapparmor1/bionic-updates,bionic-security 2.12-4ubuntu5.1 amd64 [может быть обновлён с: 2.12-4ubuntu5]
libappstream4/bionic-updates 0.12.0-3ubuntu1 amd64 [может быть обновлён с: 0.12.0-3]
libapt-inst2.0/bionic-updates 1.6.8 amd64 [может быть обновлён с: 1.6.3ubuntu0.1]
libapt-pkg5.0/bionic-updates 1.6.8 amd64 [может быть обновлён с: 1.6.3ubuntu0.1]
libarchive13/bionic-updates,bionic-security 3.2.2-3.1ubuntu0.2 amd64 [может быть обновлён с: 3.2.2-3.1ubuntu0.1]
libasound2/bionic-updates 1.1.3-5ubuntu0.2 amd64 [может быть обновлён с: 1.1.3-5ubuntu0.1]
libasound2-data/bionic-updates,bionic-updates 1.1.3-5ubuntu0.2 all [может быть обновлён с: 1.1.3-5ubuntu0.1]
libavahi-client3/bionic-updates,bionic-security 0.7-3.1ubuntu1.2 amd64 [может быть обновлён с: 0.7-3.1ubuntu1.1]
libavahi-common-data/bionic-updates,bionic-security 0.7-3.1ubuntu1.2 amd64 [может быть обновлён с: 0.7-3.1ubuntu1.1]
libavahi-common3/bionic-updates,bionic-security 0.7-3.1ubuntu1.2 amd64 [может быть обновлён с: 0.7-3.1ubuntu1.1]
libavahi-core7/bionic-updates,bionic-security 0.7-3.1ubuntu1.2 amd64 [может быть обновлён с: 0.7-3.1ubuntu1.1]
libavahi-glib1/bionic-updates,bionic-security 0.7-3.1ubuntu1.2 amd64 [может быть обновлён с: 0.7-3.1ubuntu1.1]
libbind9-160/bionic-updates 1:9.11.3+dfsg-1ubuntu1.3 amd64 [может быть обновлён с: 1:9.11.3+dfsg-1ubuntu1.1]
libblkid1/bionic-updates 2.31.1-0.4ubuntu3.3 amd64 [может быть обновлён с: 2.31.1-0.4ubuntu3.1]
libcaca0/bionic-updates,bionic-security 0.99.beta19-2ubuntu0.18.04.1 amd64 [может быть обновлён с: 0.99.beta19-2build2~gcc5.3]

Аватара пользователя

aleks@
Сообщения: 450
Зарегистрирован: 03 дек 2013, 17:48

Re: обновления програмного обеспичения

#5

Сообщение aleks@ » 05 фев 2019, 00:55

У знакомого была такая же проблема, подключал интернет на ноуте по wi-fi со смартфона. Посмотрите в этой теме
viewtopic.php?f=15&t=4128
работает нормально, клик по иконке, пароль, Enter, все обновления установятся сами и терминал закроется. Удобно на слабом ноуте, все обновления отключаются, удаляется update-manager, отключаются даже поиск обновлений, чтобы не грузило слабый процессор. Обновления делаются только по желанию.


MikeRM
Сообщения: 61
Зарегистрирован: 19 окт 2018, 19:53

Re: обновления програмного обеспичения

#6

Сообщение MikeRM » 05 фев 2019, 01:06

Пока никакого криминала. А если попробовать обновиться:

Код: Выделить всё

sudo apt upgrade


Автор темы
krapov
Сообщения: 12
Зарегистрирован: 03 янв 2018, 00:05

Re: обновления програмного обеспичения

#7

Сообщение krapov » 05 фев 2019, 12:20

Это в терминале после "sudo apt upgrade"

Код: Выделить всё

E: Не удалось получить https://deb.opera.com/opera-stable/pool/non-free/o/opera-stable/opera-stable_57.0.3098.76_amd64.deb  404  Not Found [IP: 151.101.114.202 443]
E: Невозможно получить некоторые архивы, вероятно надо запустить apt-get update или попытаться повторить запуск с ключом --fix-missing


MikeRM
Сообщения: 61
Зарегистрирован: 19 окт 2018, 19:53

Re: обновления програмного обеспичения

#8

Сообщение MikeRM » 05 фев 2019, 14:39

Сделайте ещё раз

Код: Выделить всё

sudo apt update
на вопрос
N: Требуется явное подтверждение, прежде чем можно будет обновить данный репозиторий. Дополнительную информацию смотрите в справочной странице apt-secure(8).
Вы хотите принять эти изменения и продолжить обновление из этого репозитория? [д/Н]
Нужно отвечать y(латинская) или д, но не d.
После этого ещё раз

Код: Выделить всё

sudo apt upgrade


Автор темы
krapov
Сообщения: 12
Зарегистрирован: 03 янв 2018, 00:05

Re: Обновление программного обеспечения

#9

Сообщение krapov » 06 фев 2019, 12:18

После подтверждения y(латинская) в терменале:
СпойлерПоказать
Хотите продолжить? [Д/н] y
Ошк:1 https://deb.opera.com/opera-stable stable/non-free amd64 opera-stable amd64 57.0.3098.76
404 Not Found [IP: 151.101.14.202 443]
E: Не удалось получить https://deb.opera.com/opera-stable/pool ... _amd64.deb 404 Not Found [IP: 151.101.14.202 443]
E: Невозможно получить некоторые архивы, вероятно надо запустить apt-get update или попытаться повторить запуск с ключом --fix-missing
А если пытаться обновиться без терменала пишет: проверте иньернет соединение но интернет есть. Тут пишет "Не удалось получить https://deb.opera.com/opera-stable/pool ... _amd64.deb 404 Not Found [IP: 151.101.14.202 443]" Опера стоит но я ей не пользуюсь в основном мазилой пользуюсь. Удалить её, штоль?


MikeRM
Сообщения: 61
Зарегистрирован: 19 окт 2018, 19:53

Re: Обновление программного обеспечения

#10

Сообщение MikeRM » 06 фев 2019, 15:29

Если в опере нет важных закладок и паролей то лучше удалить вместе с ppa:

Код: Выделить всё

sudo apt remove opera
sudo add-apt-repository --remove 'deb https://deb.opera.com/opera-stable/ stable non-free'
Поставить обратно можно с офф. страницы из deb, как рекомендует сама опера.

Ответить