Страница 1 из 1

lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 08 сен 2019, 11:34
agerbrown
во время просмотра видео, через 10-15мин гаснут все мониторы, что заставляет подойти к ПК и пошевелить мышкой
как отключить энергосбережение, гуглю уже месяц, ничего не помогло

Re: lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 09 сен 2019, 18:50
denkin
lightlocker удалить или убрать из автозагрузки?

Re: lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 10 сен 2019, 06:49
count0
Есть ещё dpms в xorg.conf. По-умолчанию он включен, поэтому даже если конфига нет - он работает. Надо конфиг создать, и прописать там в секции Монитор:

Код: Выделить всё

Section "Monitor"
Option          "DPMS" "false"
EndSection 
Либо скрипт в крон:

Код: Выделить всё

pm-powersave false
xset dpms 0 0 0
xset -dpms
xset s 0 0
xset s off
xset s noblank
xset q | grep "DPMS is"
Сколько он мне крови попил на ноуте когда сидел...

Re: lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 10 сен 2019, 07:33
agerbrown
спасибо, конфиг я знаю как прописать, а вот по поводу скрипта хотелось бы более подробных инструкций, начал пользовать лубунту только этим летом

Re: lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 10 сен 2019, 07:51
agerbrown
count0, создал xorg.conf в /usr/share/X11/xorg.conf.d
правильно?
а вот как скрипт в крон сделать не понимаю, но надеюсь не понадобится

Re: lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 10 сен 2019, 08:38
agerbrown
count0, созданный xorg.conf приводит к тому, что система грузится в чёрный экран, пришлось выйти в консоль и через sudo nano вычистить содержимое файла

Re: lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 10 сен 2019, 13:16
agerbrown
count0, скрипт помог, а кронтаб не заработал
создал файл dpms.sh
SHELL=/bin/bash
pm-powersave false
xset dpms 0 0 0
xset -dpms
xset s 0 0
xset s off
xset s noblank
xset q | grep "DPMS is"
затем в окне session manager в preferences > lxqt settings
во вкладке autostart добавил строчку
bash /home/agerbrown/dpms.sh

после чего перезагрузился
мониторы перестали гаснуть, это полностью решило проблему.
Большое спасибо, всё лето не мог побороть это

Re: lubuntu 18.10 отключить энергосбережение монитора

Добавлено: 06 ноя 2019, 03:29
count0
У меня полностью прописанный конфиг в

Код: Выделить всё

/etc/X11/xorg.conf.d/nvidia.conf
, я туда добавлял. Можно туда микро-файл с этой секцией. Но раз не пошло, так и ладно. Хоть скриптом, да победили :good: