Error: Electrum requires Python version >= 3.6.1...

Модератор: Vadim

Ответить

Автор темы
lubuntu6
Сообщения: 2
Зарегистрирован: 04 ноя 2018, 17:04

Error: Electrum requires Python version >= 3.6.1...

#1

Сообщение lubuntu6 » 19 янв 2019, 12:59

Всем привет ! Может кто сталкивался с такой проблемкой )
При установки Electrum через терминал, командами :
Install dependencies:
sudo apt-get install python3-setuptools python3-pyqt5 python3-pip
Install Electrum:
sudo python3 -m pip install https://download.electrum.org/3.3.2/Ele ... ctrum[fast]

Получается такая ошибка:

The directory '/home/my idrectory/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/my idrectory/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled.

Error: Electrum requires Python version >= 3.6.1...

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-3246txsb/electrum/
You are using pip version 8.1.1, however version 18.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

И после обновления Python до версии 3.6.7 и pip с 8.1.1 до 18.1:
pip --version
pip 18.1 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)

все равно наблюдаю ту же ошибку:
You are using pip version 8.1.1, however version 18.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command
Люди добрые если у кого есть какие либо идеи отпишите пожалуйста ! Спасибо

Аватара пользователя

zhart
Администратор
Сообщения: 1808
Зарегистрирован: 16 дек 2010, 13:09
Контактная информация:

Re: Error: Electrum requires Python version >= 3.6.1...

#2

Сообщение zhart » 19 янв 2019, 14:05

lubuntu6, а какая версия системы? 16.04?
У меня на 16.04 такая же беда с Blender 2.8 beta — тоже требует python 3.6, и тоже после обновления python до 3.6 (из ppa) продолжает выдавать ту же ошибку (требует python 3.6 при том, что он уже установлен). Пока решил установкой snap-версии, да и бинарник из скачанного напрямую архива тоже запускается. Проблема только с неразрешенной зависимостью python 3.6 при установке из ppa.

P.S.: Понимаю, что Electrum и Blender — совершенно разные приложения, но предполагаю, что проблема может быть общей, поэтому и пишу.


Автор темы
lubuntu6
Сообщения: 2
Зарегистрирован: 04 ноя 2018, 17:04

Re: Error: Electrum requires Python version >= 3.6.1...

#3

Сообщение lubuntu6 » 19 янв 2019, 16:58

Zhart Спасибо !
Да юзаю 16.04
На данный момент проблема только с pip 8.1.1 , с python 3.6 проблема была решена c помощью этих команд:

1.
sudo add-apt-repository ppa:jonathonf/python-3.6

2.
sudo apt-get update
sudo apt-get install python3.6

3.
sudo update-alternatives --config python3

python3 -V

Аватара пользователя

zhart
Администратор
Сообщения: 1808
Зарегистрирован: 16 дек 2010, 13:09
Контактная информация:

Re: Error: Electrum requires Python version >= 3.6.1...

#4

Сообщение zhart » 19 янв 2019, 21:08

lubuntu6 писал(а):
19 янв 2019, 16:58
На данный момент проблема только с pip 8.1.1
А обновление точно произошло? Какой номер версии выводится при вводе в консоли:

Код: Выделить всё

python -c "import pip; print(pip.__version__)"
?

Наткнулся на вот это обсуждение, там вроде удалось решить проблему, причем есть разные рабочие решения.

Одно из них (две последовательные команды в консоли):

Код: Выделить всё

sudo apt remove python3-pip
python get-pip.py

Аватара пользователя

chadwick
Сообщения: 192
Зарегистрирован: 07 авг 2016, 03:09

Re: Error: Electrum requires Python version >= 3.6.1...

#5

Сообщение chadwick » 19 янв 2019, 21:30

lubuntu6 писал(а):
19 янв 2019, 12:59
И после обновления Python до версии 3.6.7 и pip с 8.1.1 до 18.1:
pip --version
pip 18.1 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
не понимаю, раз ему нужен python3, то причем здесь pip и python2

Код: Выделить всё

~$ pip3 --version
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.5)
обновлять вот этой командой (наверное) ->

Код: Выделить всё

~$ pip3 install --upgrade pip3
только перед обновлением нужно будет удалить python3-pip (наверное)

но я бы сначала попробовал установить в домашний каталог, без sudo ->

Код: Выделить всё

~$ pip3 install https://download.electrum.org/3.3.2/Electrum-3.3.2.tar.gz
и вот эти пакеты тоже пригодятся (наверное) ->

Код: Выделить всё

~$ sudo apt-get install python3-dev python3-psutil python3-wheel

Ответить