Обновление из этого репозитория Тема решена

Модератор: Vadim

Ответить

Автор темы
Bessok
Сообщения: 2
Зарегистрирован: 27 янв 2019, 04:21

Обновление из этого репозитория

#1

Сообщение Bessok » 27 янв 2019, 05:03

Ребята Добрый день/вечер. Немножко истории и извините если не туда написала.
СпойлерПоказать
На днях купил себе 55 диагональ телевизора (без Смарта) и у друга забрал старенький неттоп на базе
Amd-e350 1.6ghz/Video 6310m/4gb/500gb 3q который уже давно у него валялся и решил я сделать из него смарт приставку (до этого был mxq) ну и установил я туда win7 и думал все будет хорошо поставил Kodi настроил но нет система тормозит очень сильно. Думал уже на Win Xp но и тут меня ожидал провал Kodi вообще не работает на данном семействе уже давно. Думал поставить Ubuntu но посмотрел на минимальные (рекомендованные) параметры и понял что это будет аналог win7. Немного посмотрел просторы интернета и нашел данную сборку все ее хвалили за малый жор системные требований поставил вроде бы все хорошо но понял что знания linux у меня 0 целых х.. ну вы поняли. Еле разобрался с терминалом с горем по полам установил kodi и о чудо все работает идеально. Решил пойти дальше установить RetroArch (мало ли потянит psp для GoD) и тут все вроде бы устанавливается и в конце пишет обновление из этого репозитория нельзя выполнить безопасным способом по этому он отключен и я понимаю что вот здесь я и остановился...
Ребята помогите что нужен сделать человеку который дуб дубом в этом всем какие команды надо прописать или что установить? Как обойти данное сообщение?

Изображение

Аватара пользователя

XapoH
Сообщения: 48
Зарегистрирован: 14 июл 2018, 21:46
Откуда: Riga

Re: Обновление из этого репозитория

#2

Сообщение XapoH » 27 янв 2019, 13:12

нич-чкго не понял из написанного.. Может потому, что не проснулся толком.
Если я не ошибаюсь, то нужны файлы какие-то из этого: https://www.launchpad.net/libretro/+packages
Вот просто туда идём, скачивает нужный deb соглсно своей версии и ставим его (запуск по ПКМ - установить)
И не нужно ничего подключать.
Только нужно быть уверенным, что это - не подстава.

ЗЫ. лаунчпадовские репы я обычно вообще не подключаю - ставлю всё именно как описал выше: через скачивание deb-пакета
Адрес легко получается путём замены в начале "ррр" на "www" и "отбрасывания" всего, что за пробелом. Т.е. вместо ppа.launchpad.net/libretro/stable/.... заводим www.launchpad.net/libretro/
вместо ppа.launchpad.net/libretro/team-xbmc/ - www.launchpad.net/libretro/team-xbmc/ и т.п.


Автор темы
Bessok
Сообщения: 2
Зарегистрирован: 27 янв 2019, 04:21

Re: Обновление из этого репозитория

#3

Сообщение Bessok » 27 янв 2019, 19:16

Я имелл в виду что я не могу установить RetroArch потому что какие то ошибки в конце и я не могу понять в чем проблема... Но тут уже ладно натикнулся на маркет вроде бы там все есть без нужды запускать терминал и прописывать отдельно но все равно спасибо хотя вообще нечего не понял из написанного)
Меня ещё интересует вот такой вопрос или правильно сказать как это сделать.
Суть такова на Windows я знаю что есть как и ихняя внутренняя программа для того что бы Android передавал изображение на систему по Wifi из одной сети или же отдельное приложение типо Mobizen. Мне интересно есть что то подобное только она Lubuntu ? Что бы оно работало по системе Mieacast (вроде бы так называется или как в Андроиде-беспроводной дисплей)


MikeRM
Сообщения: 61
Зарегистрирован: 19 окт 2018, 19:53

Re: Обновление из этого репозитория

#4

Сообщение MikeRM » 27 янв 2019, 19:33

Код: Выделить всё

[E: Репозиторий «http://ppa.launchpad.net/libretro/stable/ubuntu cosmic Release» не содержит файла Release.
Ветвь stable retroarch для 18.10 по каким-то причинам недоступна (лучше у мейнтейнера узнать почему). Поставьте из тестинга если вам не принципиально, там таких ошибок у меня не возникло:

Код: Выделить всё

sudo add-apt-repository --remove ppa:libretro/stable
sudo add-apt-repository ppa:libretro/testing
XapoH, вы зачем человеку жизнь портите, он и так в линуксе не очень. Качать и ставить отдельные deb пакеты это windows way и верный способ спустя два месяца переставить систему с нуля из-за неразрешённых зависимостей. Пусть apt поработает - не заработала софтина удалил через него же, и репозиторий подтёр следом. А то так можно скатиться до установки из flatpak (от npm то никак ни уйти до сих пор).

Аватара пользователя

XapoH
Сообщения: 48
Зарегистрирован: 14 июл 2018, 21:46
Откуда: Riga

Re: Обновление из этого репозитория

#5

Сообщение XapoH » 15 фев 2019, 19:36

MikeRM писал(а):
27 янв 2019, 19:33
Качать и ставить отдельные deb пакеты это windows way и верный способ спустя два месяца переставить систему с нуля из-за неразрешённых зависимостей.
ИМХО - смотря какие пакеты ставить. Опять же нормальный deb или уже имеет в себе все зависимости или подтаскивает их из нета (установщик всёпроверяет перед инстаяцией. И да - видел кривые пакеты без зависимостей. Обычно они или ничего из себя не представлют, или старые версии программ пересобранные для новых версий бУнты) Да и тот же apt, по сути, делает тоже самое - скачивает deb и ставит его.

ЗЫ. Ставлю себе только так. Никаких проблем. В конце-коцов есть sudo apt autoupdate

Аватара пользователя

zhart
Администратор
Сообщения: 1820
Зарегистрирован: 16 дек 2010, 13:09

Re: Обновление из этого репозитория

#6

Сообщение zhart » 16 фев 2019, 12:09

Согласен с MikeRM, ручная установка deb-пакета — крайняя мера, когда других вариантов нет. Вручную скачивать и устанавливать deb из ppa, если есть возможность прописать этот самый ppa себе в систему — вариант по меньшей мере странный.

Аватара пользователя

XapoH
Сообщения: 48
Зарегистрирован: 14 июл 2018, 21:46
Откуда: Riga

Re: Обновление из этого репозитория

#7

Сообщение XapoH » 16 фев 2019, 18:02

zhart писал(а):
16 фев 2019, 12:09
Согласен с MikeRM, ручная установка deb-пакета — крайняя мера, когда других вариантов нет. Вручную скачивать и устанавливать deb из ppa, если есть возможность прописать этот самый ppa себе в систему — вариант по меньшей мере странный.
С одной стороны как бы и правильно (я и сам по началу так делал), но с другой (как по мне) - единственные ppa, которым я доверяю, это официальные. А все остальные прописываются "на свой страх и риск" - прецеденты, что вместе с обновлениями прилетало что-то непонятное у народа уже вроде были. Единственное, это прописать-поставть-удалить_ppa, но телодвижений это требует больше. Особенно если речь идёт о переустановке одного и того же


ВикторА
Сообщения: 467
Зарегистрирован: 06 ноя 2011, 11:10

Re: Обновление из этого репозитория

#8

Сообщение ВикторА » 23 фев 2019, 00:04

XapoH писал(а):
15 фев 2019, 19:36
MikeRM писал(а):
27 янв 2019, 19:33
Качать и ставить отдельные deb пакеты это windows way и верный способ спустя два месяца переставить систему с нуля из-за неразрешённых зависимостей.
ИМХО - смотря какие пакеты ставить. Опять же нормальный deb или уже имеет в себе все зависимости или подтаскивает их из нета (установщик всёпроверяет перед инстаяцией. И да - видел кривые пакеты без зависимостей. Обычно они или ничего из себя не представлют, или старые версии программ пересобранные для новых версий бУнты) Да и тот же apt, по сути, делает тоже самое - скачивает deb и ставит его.

ЗЫ. Ставлю себе только так. Никаких проблем. В конце-коцов есть sudo apt autoupdate
Вот что спустя некоторое время могут быть проблемы-это да...Но "нормальность" деба не оценивается наличием-отсутствием в нем зависимостей. Скорее, это зависит от условий и целей компиляции и иногда на одном компе пакет установится, а на другом, он же, может потребовать зависимости...и сам он не подтаскивает их из интернета...Зависимости помогает разрешить apt при установке сразу. А если пакет скачать без установки, то в системе он же потом устанавливается через dpkg (как составляющая apt-a), и если чего-то не хватает, то dpkg не установит, но укажет, что того-то и того-то не хватает...У меня такие случаи были, когда ставил пакеты из системы ране скачанные...Поэтому лучше использовать репы и сразу apt. И удалять потом тоже лучше через apt - так система чище .

Ответить